В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
TaPo4оК
TaPo4оК
27.01.2020 20:54 •  Информатика

вычислить объем шара составить программу в pascal abc​

Ответ:
osama95w
osama95w
21.11.2020 00:23

Объяснение:

program vshara;

var i, d, r, v: real;

begin

 Write('Вычисление объёма шара через радиус (1) или диаметр (2)(число пи = 3,14) (введите требуемую цифру): ');

 Read(i);

 if i=1 then

   begin

     Write ('Введите радиус: ');

     Read(r);

     v:=4*3.14*r*r*r/3;

     Write ('Объём шара равен ', v);

     Readln;

   end;

 if i=2 then

   begin

     Write ('Введите диаметр: ');

     Read(d);

     v:=3.14*d*d*d/6;

     Write ('Объём шара равен ', v);

     Readln;

   end;

 Readln;

End.


вычислить объем шара составить программу в pascal abc​
вычислить объем шара составить программу в pascal abc​
0,0(0 оценок)
Ответ:
mitioglodima81
mitioglodima81
21.11.2020 00:23

Это если нужно более элегантное решение:

begin

 var radius := ReadReal('Введите радиус шара:');

 var volume := 4/3 * Pi * radius**3;

 Print('Объем шара:', volume);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?