В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kola3344
kola3344
13.07.2020 00:32 •  Информатика

Решить в паскале: составить программу,проверяющую,является ли заданное натуральное число палиндромом,т.е. таким,которое читается одинаково слева направо и справа налево(например: 23132).

Ответ:
МаринаДоблер
МаринаДоблер
10.06.2020 23:24

var n, m, p: word;
begin
write('Enter number: ');
readln(n);
m := n;
p := 0;
while m > 0 do begin
p := p * 10 + m mod 10;
m := m div 10;
end;
if n = p then
writeln('Palindrome')
else
writeln('Not palindrome');
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?