В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу по определению,попадает ли точка в синюю область .


Написать программу по определению,попадает ли точка в синюю область .
Написать программу по определению,попадает ли точка в синюю область .

Ответ:
MashaFox25
MashaFox25
19.11.2020 05:52

1)

program z1;

var x,y: integer;

begin

write ('x = ');

readln (x);

write ('y = ');

readln (y);

if (y>0) and (x*x+y*y<4) then writeln('Точка попадает в синюю область')

else writeln('Точка не попадает в синюю область')

end.

2)

program z1;

var x,y: integer;

begin

write ('x = ');

readln (x);

write ('y = ');

readln (y);

if (x<0) and(y<0) and (x*x+y*y<5) then writeln('Точка попадает в синюю область')

else writeln('Точка не попадает в синюю область')

end.

Объяснение:

Проекции точки на оси x и y являются катетами прямоугольного треугольника. Гипотенуза - расстояние от начала координат до точки.

Чтобы точка принадлежала кругу расстояние до точки должно быть меньше радиуса.

Поскольку здесь половина и четверть круга, добавляем ограничения по х и у.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?