В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alenka199918
alenka199918
26.08.2022 17:32 •  Информатика

Написать программу, которая вводит с клавиатуры не пустой массив целых чисел, печатает его, затем находит максимальный и минимальный элемент массива, выводит их на экран.

Ответ:
molkes
molkes
10.06.2020 22:32

var  a: array [1..100] of integer;
i,n,min,max:integer;
Begin
    read(n);
    for i := 1 to n do
        read(a[i]);

    min:=a[1];
    max:=a[1];
    for i:= 1 to n do begin
        write(a[i],' ');
        if max<a[i] then max:=a[i];
        if min>a[i] then min:=a[i];
    end;
    writeln(min,max);
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?