В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alinachaiun
alinachaiun
20.06.2022 18:04 •  Информатика

Составить программу вставки в массив a(n) первого элемента, равного 7

Ответ:
asyazakharchenko3011
asyazakharchenko3011
30.09.2020 19:25

var a:array [1..100] of integer;
i,n:integer;
Begin
     read(n);
     for i:= 1 to n do
         read(a[i]);

     for i:= n downto 1 do
         a[i+1]:=a[i];

     a[1]:=7;

     for i:=1 to n+1 do
         write(a[i],' ');
End.

0,0(0 оценок)
Ответ:
nyarokhno
nyarokhno
30.09.2020 19:25

Program R1;
Var a:array[1..100] of integer;
i,n:integer;
begin
assign(input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
readln(n);
for i:=1 to n do read(a[i]);
for i:=n+1 downto 2 do
a[i]:=a[i-1] ;
a[1]:=7 ;

for i:=1 to n+1 do write(a[i],' ');
close(input);
close(output);
end.

 например

ввод

4

1 2 3 4 

 вывод 

7 1 2 3 4

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?