В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bluecat12
bluecat12
12.10.2020 01:46 •  Информатика

На Python Составьте программу для решения следующей задачи: Клиент кладет в банк сумму Х, под процент P. Сколько у него будет через N лет, если каждый год он будет снимать со счета сумму K​

Ответ:
Kottenok2005
Kottenok2005
18.11.2020 21:27

N = float(input('Кол-во лет: '))

P = float(input('Кол-во процентов: '))

X = float(input('Сумма на счету: '))

K = float(input('Сумма снятия в год: '))

for i in range(int(N)):

   X = ( X + X * (P/100)) - K

print(f'Через {int(N)} лет у тебя будет целых {X} рублей, хватит на мороженое и дошик.')

Держи. Если я не накосячил нигде, то это верная прога. Проверь в питоне с числами

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?