В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу на языке pascal для вычисления угла возвышения дальнобойного орудия по начальной скорости полета снаряда и дальности цели. сопротивлением воздуха и высотой орудия пренебречь.

Ответ:
nightlovell15
nightlovell15
10.06.2020 18:21

Сначала решим физическую задачу:

Дано:

v₀;

L;

Найти:

γ;

Решим систему ур-й описывающих движение:

y(t)=v₀Δt·sinγ - ½gΔt²

x(t)=v₀Δtcosγ;

В момент времени Пусть Δt = τ   x(t)=L, тогда y(t)=0 ⇒

τ= L ÷ v₀cosγ (из ур-я x(t))

из ур-я y(t)

L·g ÷ v₀²=sin2γ

γ = ½arcsin (Lg ÷ v₀²) - Это конечная формула

ответ: γ = ½ arcsin(Lg ÷ v₀²);

 

Теперь код программы (PascalABC.NET):

//Если угол нужен в радианах

Program bullet_rad;

Const
g_grav = 9.8; // гравитационная постоянная g=9,8

Var
L, //Расстояние до цели
v: real; //Начальная скорость снаряда

Begin
readln (L,v); // Читаем расстояние и скорость
writeln (0.5*arcsin((L*g_grav)/sqr(v))); //Выводим ответ
End.

 

//Если угол нужен в градусах

Program bullet_gr;

Const
g_grav = 9.8; // гравитационная постоянная g=9,8
pi = 3.14; // постоянная п=3,14

Var
L, //Расстояние до цели
v: real; //Начальная скорость снаряда

Begin
readln (L,v); // Читаем расстояние и скорость
writeln ((90/pi)*arcsin((L*g_grav)/sqr(v))); //Выводим ответ
End.

0,0(0 оценок)
Ответ:
LevMuronov
LevMuronov
10.06.2020 18:21

Решим систему ур-й описывающих движение:

y(t)=v₀Δt·sinγ - ½gΔt²

x(t)=v₀Δtcosγ;

В момент времени Пусть Δt = τ   x(t)=L, тогда y(t)=0 ⇒

τ= L ÷ v₀cosγ (из ур-я x(t))

из ур-я y(t)

L·g ÷ v₀²=sin2γ

γ = ½arcsin (Lg ÷ v₀²) - Это конечная формула

ответ: γ = ½ arcsin(Lg ÷ v₀²);

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?