В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
karnastia
karnastia
20.09.2021 08:51 •  Информатика

Составить программу на языке программирования visual c++! два автомобиля движутся по кольцевой дороге длины l в противоположных направлениях. они начинают движение из одной точки и едут с постоянными скоростями v1 и v2 соответственно. требуется определить, на каком расстоянии друг от друга они окажутся в момент времени t. на вход 4 натуральных числа l, v1, v2, t, разделенных пробелом. все числа не превосходят 100. выведите расстояние между автомобилями в момент времени t – длину кратчайшей из двух дуг дороги между автомобилями.

Ответ:
юра416
юра416
30.09.2020 19:17

#include<iostream>
using namespace std;
int main(){
  int l,v1,v2,t;
  cin>>l>>v1>>v2>>t;
  int x1 = (t * v1)%l,x2 = (-t*v2)%l;
  if(x1<0) x1=l-x1;
  if(x2<0) x2=l+x2;
  cout<<min(abs(x1-x2),abs(l-x1-x2));
}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?