В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
anjelela799
anjelela799
11.11.2020 10:26 •  Информатика

Написать программу в паскале: 1) вводятся 10 целых чисел. подсчитать количество четных среди них 2) вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры). 3) вывести на экран все трехзначные числа-палиндромы, т.е. такие числа, которые одинаково читаются как слева направо, так и справа налево.

Ответ:
Маришка1231
Маришка1231
10.06.2020 16:17

var

  i, c : byte;

  t : integer;

begin

  c := 0;

  for i := 1 to 10 do

  begin

    read (t);

    if t mod 2 = 0 then inc (c);

  end;

  writeln (c);

end.

 

var

  n, i : integer;

begin

  read (n);

  for i := 100 to 999 do

    if i mod 10 + i div 10 mod 10 + i div 100 = n then writeln (i);

end.

 

var

  i : integer;

begin

  for i := 100 to 999 do

    if i mod 10 = i div 100 then writeln (i);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?