В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
NEASA
NEASA
04.03.2021 08:15 •  Информатика

Решите в тетради , используя цикл while-wend 1. написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры

Ответ:
sinyavska1988
sinyavska1988
30.09.2020 19:14

begin

read(n);

while (n <> 0) do // пока не равно нулю делать

 begin

 s := s + n;

 k = k + 1;

 end.

writeln(s/k); // среднее

writeln(s); // сумма

end.

Переменные сам объяви. s и к должны быть типа real

Если что-то не понятно пиши в ЛС

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?