В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Поменяйте местами k1-ый и k2-ой элементы данного массива размерностью N (N < 50). И выведите все элементы по порядку. Формат входных данных

N - количество элементов в массиве Arr

Arrn - элементы массива (-50 < Arrn < 50)

k1, k2 - элементы массива, которые необходимо поменять местами.

Формат выходных данных

Строка, содержащая элементы массива, полученного после перестановки, записанные по порядку через пробел.

входные данные

6

-16 -7 -10 6 -11 10

5 6

выходные данные

-16 -7 -10 6 10 -11
Решить в c++

Ответ:
Vita1968
Vita1968
28.09.2020 15:01

int arr[SIZE] = {-16, -7, -10, 6, -11, 10};

temp = arr[k2];

arr[k2] = arr[k1];

arr[k1] = temp;

for (int i = 0; i < SIZE; i++)

 std::cout << arr[i] << "\t";

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?