В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
golubalex01
golubalex01
21.01.2020 19:41 •  Информатика

40 напишите программу в паскале с оператором repeatдано целое число n (> 0) используя операции деления нацело и взятия остатка от деления, найти количество и сумму его цифр (n=63)

Ответ:
jefimmalinovski
jefimmalinovski
10.06.2020 13:11

program raf105;

var abc,a,sum,count: integer;

begin

write('Введите число: ');

readln(abc);

count:= -1;

repeat

 a:= abc mod 10;

 sum:= sum+a;

 count:= count+1;

 abc:= abc div 10;

until a=0;

writeln('Сумма цифр: ',sum);

writeln('Количество цифр: ',count);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?