В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hxnsksjsjsks
hxnsksjsjsks
16.05.2020 03:07 •  Информатика

СОСТАВИТЬ ПРОГРАММУ НА ПИТОНЕ Дано натуральное число n. Составить программу вывода цифр, не входящих в десятичную запись числа n (в порядке возрастания). Например: в числе 357 нет цифр: 0, 1, 2, 4, 6, 8, 9.

Ответ:
Fajeh
Fajeh
20.10.2020 20:34

#первое что пришло в голову

numbers = [0,1,2,3,4,5,6,7,8,9]

n = int(input())

n2 = []

k = 0

while n > 0:

   k = n % 10

   n2.append(k)

   n = n // 10

n2.reverse()

for i in range(len(numbers)):

   if numbers[i] not in n2:

       print(numbers[i],end=" ")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?