В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Albert116
Albert116
04.11.2021 03:49 •  Информатика

Напишите программу, которая вводит трехзначное число и находит сумму цифр этого числа.

Ответ:
KateKeta
KateKeta
10.06.2020 12:35

var

a,b,c,n,s: integer;

begin

readln(n);

if ((n>99) and (n<1000)) then

begin

a:=n div 100;

b:=n div 10 mod 10;

c:=n mod 10;

s:=a+b+c;

writeln('Сумма трех цифр равна ',s);

end else writeln('Введите трехзначное число!');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?