В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
BEDmil00
BEDmil00
28.04.2021 13:32 •  Информатика

Дан массив случайных чисел а [1..6] из промежутка [-10; 14]. составить программу нахождения суммы положительных элементов массива.

Ответ:
22a03a1989
22a03a1989
10.06.2020 11:24

program raf105;

var  

 a: array[1..6] of integer;

 i,sum: integer;

begin

for i:=1 to 6 do

begin

 a[i]:= random(-10,14);

 if a[i] > 0

   then sum+= a[i];

 writeln(a[i]);

end;

writeln('Сумма положительных элементов: ',sum);

end.

Язык PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?