В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
RuStAm09
RuStAm09
22.03.2020 07:05 •  Информатика

1. составить программу для нахождения корней квадратного уравнения с использованием уравнений виета. на входе - коэффициенты уравнения, на выходе - корни.2. составить программу, определяющую, какой четверти декартовой системы координат принадлежит точка (х, у). на на входе - координаты точки, а на выходе - номер четверти​

Ответ:
dashalarkina131
dashalarkina131
10.06.2020 07:19

Объяснение:

var a,b,c: real;

   x1,x2,D: real;

begin

 readln(a,b,c);

 D := b*b - 4*a*c;

 if D<0 then

   writeln('Корней нет')

 else if D=0 then begin

   x1 := -b/2/a;

   writeln('x1=x2=',x1);

 end

 else begin

   x1 := (-b-sqrt(D))/2/a;

   x2 := (-b+sqrt(D))/2/a;

   writeln('x1=',x1,' x2=',x2);

 end;

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?