В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу, которая будет менять местами цифры (единицы и десятки) в двузначных целых числах. Пример: 79 97

Ответ:
kariiinka
kariiinka
15.10.2020 18:34

На питоне.

print(input("Введите двузначное число: ")[::-1])

Объяснение:

Используется срез строки.

0,0(0 оценок)
Ответ:
ctc76
ctc76
15.10.2020 18:34

var

a:integer;

b,c:integer;    

t:integer;

begin

 writeln('Введите двухзначное челое число');

 readln(a);

 if not((a>9)and(a<100)and(a mod 10<> 0))then

   writeln('ERROR');

 if (a>9)and(a<100)and(a mod 10 <> 0)then

 begin

   b := a div 10;

   c := a mod 10;

   t := b-c;

   if t<0 then a:=a+abs(t*10)+t

   else a:= a-t*10+t;

   writeln(a)

 end;  

 end.

Объяснение:

Данная программа написана на Pascal

В программе я также исключил все числа 10,20,30,40,50,60,70,80,90 , так как при смене местами числа будут получаться однозначные(1,2,3,4,5,6,7,8,9)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?