В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
liana200671
liana200671
25.10.2022 06:02 •  Информатика

Напишите программу вычисления наибольшего общего делителя двух целых чисел. а)с оператором repeat б) с оператором while

Ответ:

по алгоритму евклида:

var a,b:integer;

begin

 readln(a,b);

 repeat

   if a>b then

     a:=a mod b

   else

     b:=b mod a;

 until (a=0) or (b=0);

 writeln(a+b);

end.

var a,b:integer;

begin

 readln(a,b);

 while (a<>0) and (b<>0) do

   if a>b then

       a:=a mod b

     else

       b:=b mod a;

 writeln(a+b);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?