В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SlavaRPSS
SlavaRPSS
08.10.2020 20:46 •  Информатика

Составить программу с оператором case , которая определяет день недели(пн(1)...вс(7)), всего дней 366

Ответ:
master204
master204
15.10.2020 18:04

#include <iostream>

using namespace std;

void findDayOfWeek(int day) {

switch (day) {

 case 1:

  cout << "Понедельник";

  break;

 case 2:

  cout << "Вторник";

  break;

 case 3:

  cout << "Среда";

  break;

 case 4:

  cout << "Четверг";

  break;

 case 5:

  cout << "Пятница";

  break;

 case 6:

  cout << "Суббота";

  break;

 case 7:

  cout << "Воскресенье";

  break;

 default:

  findDayOfWeek(day - 7);

}

}

int main() {

setlocale(0, "RU");

int day;

cin >> day;

findDayOfWeek(day);

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?