В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Amirhan003
Amirhan003
27.11.2020 12:27 •  Информатика

Напишите программу, которая находит в массиве целых чисел количество элементов, равных заданному значению x . возможно решать по-разному, например, использовать дополнительные массивы или даже не использовать массивы совсем. главное - вывести правильный ответ. вы должны ввести полный текст программы на java: необходимые импорты, один public класс в пакете по умолчанию (в коде отсутствует подстрока package), функцию комментарии на кириллице не разрешены. ввод осуществляется с консоли, вывод - на консоль. программа должна работать точно по протоколу, который показан в примерах. например, нельзя выводить ничего лишнего, скажем, фразу "введите n". входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. в третьей строке записано число x. гарантируется, что данные корректны и n < 10001. выходные данные программа должна вывести одно целое число – количество элементов массива, равных x . for example: } на java

Ответ:
Oladushek3000
Oladushek3000
25.01.2024 23:33
import java.util.Scanner;

class Main {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);

// Ввод размера массива
int n = in.nextInt();
in.nextLine();

// Ввод элементов массива
int[] arr = new int[n];
String[] elements = in.nextLine().split(" ");
for (int i = 0; i < n; i++) {
arr[i] = Integer.parseInt(elements[i]);
}

// Ввод значения x
int x = in.nextInt();

// Подсчет количества элементов, равных x
int count = 0;
for (int i = 0; i < n; i++) {
if (arr[i] == x) {
count++;
}
}

// Вывод результата
System.out.println(count);
}
}

Программа начинается с импорта класса Scanner из пакета java.util. Далее объявляется класс "Main" с методом "main", который является точкой входа в программу.

В методе "main" создается объект класса Scanner для чтения ввода с консоли. Затем происходит ввод размера массива "n" и переход на следующую строку (с помощью метода nextLine() после nextInt(), чтобы пропустить символ новой строки).

Затем создается массив "arr" размером "n". В строке, содержащей элементы массива, происходит разделение по пробелу с помощью метода split(" "), чтобы получить отдельные элементы. Затем каждый элемент преобразуется из строки в целое число с помощью метода parseInt() и сохраняется в массиве.

После ввода элементов массива происходит ввод значения "x".

Затем идет подсчет количества элементов в массиве, равных "x". Итерации выполняются для каждого элемента массива "arr". Если текущий элемент равен "x", то переменная "count" увеличивается на 1.

В конце программы выводится результат - значение переменной "count".
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?