В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ksenya5727
Ksenya5727
24.09.2020 10:43 •  Информатика

Написать программу на питонПостроение кривой дракона Кривая дракона — один из наиболее известных фракталов. Она строится так: на первом шаге проводится отрезок из начала координатной плоскости в точку (0;1). Далее на каждом шаге из конца фрактала повторяется уже нарисованная часть фигуры, повернутая на 90 градусов против часовой стрелки. Рассмотрим кривую дракона на шаге номер n≥2. Вы движетесь из точки (0,0) и выписываете направления поворотов после прохождения каждого отрезка. Поворот направо обозначается буквой R, поворот налево — буквой L. Выведите последовательность поворотов. Входные данные Задано натуральное число n (2≤n≤15). Выходные данные Программа должна вывести последовательность из букв L и R в одной строке без пробелов.

Ответ:
viktoriafedorip0a2an
viktoriafedorip0a2an
15.10.2020 16:25

Если движение (0; 0) -> (0; 1) - это движение вверх по ОY, то поворот на 90 градусов против часовой стрелки даёт R.

Код:

def invert_path(d: str):

   r = {

       "L": "R",

       "R": "L",

   }

   return r[d]

def dragon(depth: int) -> str:

   if depth == 1:

       return

   yield from dragon(depth-1)

   yield "R"

   second_part = dragon(depth-1)

   yield from (invert_path(x) for x in reversed(list(second_part)))

n = int(input())

print("".join(dragon(n)))

===================================

Если ответ удовлетворил, не забудь отметить его как "Лучший".


Написать программу на питонПостроение кривой дракона Кривая дракона — один из наиболее известных фра
Написать программу на питонПостроение кривой дракона Кривая дракона — один из наиболее известных фра
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?