В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Helponator
Helponator
25.10.2021 20:14 •  Информатика

Напишите программу, которая в последовательности целых чисел определяет сумму двух наибольших и сумму двух наименьших. Программа должна вывести две этих суммы в указанном порядке. Программа получает на вход целые числа, количество введённых чисел не известно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. В последовательности не менее двух чисел. На ПИТОНЕ

Ответ:
tarnopolska99
tarnopolska99
15.10.2020 16:22

Код:

sequence = []

while True:

   n = int(input())

   if n == 0:

       break

   sequence.append(n)

sequence.sort()

smin = sequence[:2]

smax = sequence[-2:]

print(sum(smax), sum(smin))

======================================================

Если ответ устроил, не забудь отметить его как "Лучший".


Напишите программу, которая в последовательности целых чисел определяет сумму двух наибольших и сумм
Напишите программу, которая в последовательности целых чисел определяет сумму двух наибольших и сумм
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?