В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
paxand
paxand
19.11.2020 08:13 •  Информатика

Составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихованной области, и false в противном Подробно Саму суть понимаю Не понимаю как считается всё что идёт после if


Составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихован

Ответ:
irinar1
irinar1
15.10.2020 16:13

Объяснение:

Мы находим функции прямых, ограничивающих область (по точкам).

Эти прямые дают координаты Y точки по её координате X.

Если некая y = f(x) в точке X0 принимает Y0 и это соответствует введенным значениям, то введенная точка лежит на прямой.

Но нам интересны значения в области. Если введенное значение Y больше рассчитанного Y0, то (X; Y) находится выше прямой y = f(x).

Если же меньше рассчитанного, то ниже.

Смотря на рисунок мы определяем, какие прямые у нас имеются, и где должна быть точка, чтобы находиться внутри области: выше или ниже прямых, ограничивающих область (для каждой прямой).

Потом переносим это в виде условия.

Пример на Python:

def get_line_by_two_points(x0: float, y0: float, x1: float, y1: float):

   def line_y(x: float):

       return (x - x0)/(x1 - x0) * (y1 - y0) + y0

   return line_y

l1 = get_line_by_two_points(-3, 7, -6, 1)  # Левая наклонная

l2 = get_line_by_two_points(7, 1, 4, 7)  # Правая наклонная

x_value = int(input("Enter an X value: "))

y_value = int(input("Enter a Y value: "))

if 1 < y_value < 7 and y_value < l1(x_value) and y_value < l2(x_value):

   print("Point is in the space!")

else:

   print("Point is NOT in the space!")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?