В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
TamaraPanova63
TamaraPanova63
05.03.2020 14:40 •  Информатика

4) Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из чисел: 3 (если все совпадают), 2 (если два совпадает) или 0 (если все числа различны). Формат входных данных Вводятся три числа. Формат выходных данных Выведите ответ на задачу. Sample Input: 1 2 3 Sample Output: 0

Ответ:
Лuзуня
Лuзуня
15.10.2020 15:51

public class MyClass {

   public static void main(String args[]) {

     System.out.println("1, 2, 3 == " + howManyEqualNumbers(new int[]{1, 2, 3}));

     System.out.println("2, 2, 3 == " + howManyEqualNumbers(new int[]{2, 2, 3}));

     System.out.println("2, 2, 2 == " + howManyEqualNumbers(new int[]{2, 2, 2}));

   }

   

   public static int howManyEqualNumbers(int[] numbers) {

       int result = 0;

       

       for (int i = 0; i < numbers.length; i++) {

           if (i == 0) {

               continue;

           }

           

           if (i == 1 && numbers[i] == numbers[i - 1]) {

               result += 2;

               

               continue;

           }

           

           if (numbers[i] == numbers[i - 1]) {

               result += 1;

               

               continue;

           }

       }

       

       return result;

   }

}

P.S.

Не забывайте нажать " ", поставить оценку, и если ответ удовлетворил, то выберите его как "Лучший" :)


4) Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?