В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
414484
414484
29.04.2023 19:40 •  Информатика

написать программу в Pascal. Нужно чтобы пользователь ввёл число из десятичной системы, а программа переводила его в двоичный код.

Ответ:
2ewgv423t
2ewgv423t
15.10.2020 15:36

program des_v_dvoich;

uses crt;

var

x,i: integer;

s:String;

begin

write('Введите десятичное число>>');

read(x);

write('Двоичное число>>');

if x<0 then begin

write('-');

x:=abs(x);

end;

if x=0 then

write ('0')

else

begin

while x<>0 do begin

if x mod 2 =1 then

s:=s+'1'

else

s:=s+'0';

x:=x div 2

end;

for i:=length(s) downto 1 do

write(s[i])

end;

end.

Объяснение:

Скрины выполнения прикреплены


написать программу в Pascal. Нужно чтобы пользователь ввёл число из десятичной системы, а программа
написать программу в Pascal. Нужно чтобы пользователь ввёл число из десятичной системы, а программа
написать программу в Pascal. Нужно чтобы пользователь ввёл число из десятичной системы, а программа
0,0(0 оценок)
Ответ:
itpediaigor
itpediaigor
15.10.2020 15:36
PascalABC.NET

Перевод целых чисел в двоичный код:

function f(x:integer):string := x>0 ? f(x div 2) + x mod 2 : ''; function ToBinaryCode(Self:integer; n:byte:=8):string; extensionmethod; begin  Result :=  if Self = 0 then '0'  else f((Self or Trunc(2**n)) and Trunc(2**n-1)).PadLeft(n, Self>0 ? '0':'1')end; begin  ReadInteger.ToBinaryCode.Print; end.

Перевод целых чисел в двоичную систему счисления:

function f(x:integer):string := x>0 ? f(x div 2) + x mod 2 : '';function Bin(x:integer):string := x=0 ? '0' : x>0 ? f(x) : '-' + f(Abs(x));begin  Print('x₂:', Bin(ReadInteger('x₁₀:')))end.

Пример работы:


написать программу в Pascal. Нужно чтобы пользователь ввёл число из десятичной системы, а программа
написать программу в Pascal. Нужно чтобы пользователь ввёл число из десятичной системы, а программа
написать программу в Pascal. Нужно чтобы пользователь ввёл число из десятичной системы, а программа
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?