В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
VasyaHrenov
VasyaHrenov
19.08.2020 00:39 •  Информатика

Составить программу на языке с++, которая решает задачу: Вычислить значение функции y=3x при х<10.3, y=2x, при x>=10.3

Ответ:
lanchik03
lanchik03
15.09.2020 06:30

Кодяра:

#include <iostream>

double F(double x) {

   if (x < 10.3)

       return 3*x;

   else

       return 2*x;

}

void print_f(double x) {

   std::cout << "x=" << x << "; F(x)=" << F(x) << std::endl;

}

int main() {

   for (double x = 5; x < 15; x += 4.3)

       print_f(x);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?