В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
natali2613
natali2613
23.07.2022 00:27 •  Информатика

Задано массив [2,7,3]. Написать программу на языке Java, которая вычислит среднее арифметическое элементов массива

Ответ:
РафикЖирафик
РафикЖирафик
15.10.2020 15:08

public class Main

{

public static void main(String[] args) {

    int x = 0;

    int[] mas = {2,7,3};

    for(int i = 0; i < mas.length; i++){

       x = x + mas[i];

    }

    int res = x/mas.length;

 System.out.println(res);

}

}

Объяснение:

public class Main

{

public static void main(String[] args) {

    int x = 0;

    int[] mas = {2,7,3}; //     объявляем массив

    for(int i = 0; i < mas.length; i++){

       x = x + mas[i]; //      Цикл, который берет каждое число массива(mas[i]), и плюс с предыдущим(2+7+3)

    }

    int res = x/mas.length;    //     x делится на длину массива(3)

 System.out.println(res); //     Вывод результата

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?