В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
qwdv
qwdv
08.10.2021 08:56 •  Информатика

C# Написать программу, содержащую класс Студент со следующими полями: Фамилия, Имя, Возраст, Группа, Отметки (использовать целочисленный массив) и методами: вывода информации о студенте и расчет среднего значения Успеваемости

Ответ:
GeorgHimik2005
GeorgHimik2005
15.10.2020 14:53

using System;

using System.Collections;

using System.Collections.Generic;

using System.Linq;

namespace CSLear

{

   partial class Program

   {

       static void Main(string[] args)

       {

           Student Лёха = new Student("Свотин", "Алексей", 21, "ПИ 2-3", new int[5] { 4, 5, 3, 5, 3, });

           Лёха.GetInfo();

           Console.WriteLine($"Отдельно выведенные оценки Лёхи: {Лёха.AverageMark}");

           Console.ReadKey();

       }

   }

   class Student

   {

       public string Surname { get; set; }

       public string Name { get; set; }

       public int Age { get; set; }

       public string Group { get; set; }

       public int[] Marks { get; set; }

       public double AverageMark => Marks.Average();

       public Student(string Surname, string Name, int Age, string Group, int[] MarkList)

       {

           this.Surname = Surname;

           this.Name = Name;

           this.Age = Age;

           this.Group = Group;

           Marks = MarkList;

       }

       public void GetInfo()

       {

           Console.WriteLine($"Студент: {Surname} {Name}\nГруппа: {Group}\nСредний : {AverageMark}");

       }

   }

}

Объяснение:

Да, в VS 2019 можно использовать кириллицу для наименования переменных.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?