В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Valera7451
Valera7451
17.02.2022 14:22 •  Информатика

Составить программу обработки списка (массива) М, состоящего из 10 элементов. Все элементы массива М, значения которых находятся в интервале от -5 до 10 возвести в квадрат. Измененный массив вывести на экран.

Ответ:
Velichkovskaya
Velichkovskaya
15.10.2020 14:44

arr = [int(i) for i in input().split()]

new_arr = []

for i in arr:

  if i>=-5 and i<=10:

       new_arr.append(i**2)

   else:

        new_arr.append(i)

[print(i, end=" ") for i in new_arr]

Краткий гайд:

arr -  исходный списокnew_arr - измененный список
Составить программу обработки списка (массива) М, состоящего из 10 элементов. Все элементы массива М
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?