В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Мишутка890
Мишутка890
13.07.2022 16:01 •  Информатика

Составьте программу на языке программирования Паскаль, в которой требуется выполнить следующие действия: • Пользователь задает с клавиатуры последовательность из n целых чисел (n также определяется пользователем). Найти среднее арифметическое чисел из этой последовательности.

Ответ:
zubtan1951
zubtan1951
15.10.2020 14:27

var N,x,S,i:integer;

   SR:real;

begin

 writeln ('кол-во чисел в последовательности N=');

 readln (N);

 S:=0;

 for i:=1 to N do

 begin

   read (x);

   S:=S+x;

 end;

 Sr:=S/N;

 Writeln('Sr=',Sr)

end.

Объяснение:

0,0(0 оценок)
Ответ:
Mишутка9887
Mишутка9887
15.10.2020 14:27

--- PascalABC.NET 3.6.2 ---

begin

 var N := ReadInteger();

 var S := ReadSeqInteger(N);

 S.Average.Println;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?