В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maximkomaxs373
maximkomaxs373
22.10.2021 20:47 •  Информатика

программа Python Составить программу для вычисления количества всех чётных двухзначных двузначных положительных чисел.

Ответ:
ник5032
ник5032
15.10.2020 14:26

В массив добавляются случайные числа в диапазоне от -150 до 150. Дальше код обрабатывает массив в соответствии с вашими требованиями (а именно: "вычисление количества всех чётных двузначных положительных чисел"). Прикрепил также скриншот с кодом и выводом компилятора:

import random

numbers = []

am = int(input("amount of numbers = "))

for i in range (am):

   numbers.append(random.randint(-150,150))

print(*numbers)

count = 0

for i in range (am):

   if ((numbers[i] % 2 == 0) and (numbers[i] > 0)):

       if (len(str(numbers[i])) == 2):

           count += 1

print ("amount of all even two-digit positive numbers = ", count)


программа Python Составить программу для вычисления количества всех чётных двухзначных двузначных по
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?