В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sofialesiuk
sofialesiuk
04.08.2020 00:34 •  Информатика

Напишите программу на PASCAL для решения следующей задачи. Пользователь вводит с клавиатуры координаты трех вершин прямоугольного треугольника: (x1, y1), (x2, y2), (x3, y3). Необходимо найти его периметр, считая, что длина каждой стороны рассчитывается по формуле: √(x2−x1)2+(y2−y1)2.

Ответ:
Almira19681
Almira19681
15.10.2020 14:23

var x1, x2, x3, y1, y2, y3, d1, d2, d3, P:real;

begin

readln(x1, y1);

readln(x2, y2);

readln(x3, y3);

d1:=sqrt(((x2-x1)*(x2-x1))+((y2-y1)*(y2-y1)));

d2:=sqrt(((x3-x2)*(x3-x2))+((y3-y2)*(y3-y2)));

d3:=sqrt(((x1-x3)*(x1-x3))+((y1-y3)*(y1-y3)));

P:=d1+d2+d3;

writeln('Периметр равен: ', round(P));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?