В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
timofee1999
timofee1999
27.02.2020 06:27 •  Информатика

Написать программу, которая выводит круговую диаграмму, отражающую товарооборот (в процентах) книжного магазина. Исходные данные (объем продаж в рублях по категориям: книги, журналы, открытки и канцтовары) вводятся во время работы программы. Пример диаграмму приведен ниже.


Написать программу, которая выводит круговую диаграмму, отражающую товарооборот (в процентах) книжн

Ответ:
rudaniladanilov
rudaniladanilov
15.10.2020 13:33

Объяснение:

clrscr;

s:=0;

writeln('Vvedite tovarooborot po vidam:');

for i:=1 to 4 do

 begin

  write(x[i],'=');

  readln(y[i]);

  s:=s+y[i];

 end;

for i:=1 to 4 do

y[i]:=y[i]*100/s;

dr:=detect;

initgraph(dr,mode,'');

xc:=GetMaxX div 2;

yc:=GetMaxY div 2;

outtextxy(Xc-80,20,'Tovarooborot po vidam, %');

b:=round(360*y[1]/100);

r:=150;

setcolor(10);

setfillstyle(1,11);

pieslice(xc,yc,0,b,r);

for i:=2 to 3 do

 begin

  a:=round(360*y[i]/100)+b;

  setcolor(10+i);

  setfillstyle(1,10+i);

  pieslice(xc,yc,a,b,r);

  b:=a;

 end;

setcolor(14);

setfillstyle(1,14);

pieslice(xc,yc,b,360,r);

for i:=1 to 4 do

 begin

  setcolor(i+10);

  setfillstyle(1,i+10);

  bar(xc+150,i*40,xc+180,i*40+20);

  setcolor(15);

  str(y[i]:0:2,st);

  outtextXY(xc+190,i*40+5,x[i]+'-'+s

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?