В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
NickWorld
NickWorld
02.02.2020 04:25 •  Информатика

Написать программу, которая находит площадь треугольника по формуле. С использованием делегатов

Ответ:
Kotova111111777
Kotova111111777
30.08.2020 11:55

using System;

namespace kp9p_pr_10_zad_6

{

   class Program

   {

       delegate void Square(double a1, double b1, double alfa1);

       static void Main(string[] args)

       {

           double a, b; // переменные для сторон a и b  

           double alpha; // переменная для угла альфа  

           Console.WriteLine("Введите значения треугольника:\n ");

           Console.Write("a: ");

           a = double.Parse(Console.ReadLine());   // ввод стороны a  

           Console.Write("b: ");

           b = double.Parse(Console.ReadLine()); // ввод стороны b  

           Console.Write("Угол альфа: ");

           alpha = double.Parse(Console.ReadLine()); // ввод угла альфа  

           sq(a, b, alpha);  

           static void sq(double a1, double b1, double alpha1) // функция sq расчета и вывода площади  

           {

               Console.WriteLine("\nПлощадь: {0}", (a1 * b1 * Math.Sin(alpha1)) / 2); // вывод и расчет площади  

           }

       }

   }

}  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?