В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lisasmirnova1
lisasmirnova1
27.11.2020 17:34 •  Информатика

Напишите программу в , C++, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6.Программа должна быть рабочей

Ответ:
ЛизаМэй
ЛизаМэй
15.10.2020 13:18

#include <iostream>

using namespace std;

int main() {

int n = 0;

setlocale (LC_ALL, "Russian");

cout << "Введите количество чисел: ";

cin >> n;

int sum(0);

int a[n];

for(int i = 0; i < n; ++i) {

 abc:

 cout << "№" << i << ": ";

 cin >> a[i];

 if(a[i]>300||a[i]%6!=0) {

  cout << "Число превышает 300 или не кратно 6. Повторите ввод" << endl;

  goto abc;

 }

 if(0 == a[i]%6) {

  sum += a[i];

 }

}

cout << "Сумма введённых чисел, кратных 6: " << sum;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?