В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
StefaMusic2006
StefaMusic2006
04.06.2022 16:57 •  Информатика

Java. Необходимо составить программу решения линейного уравнения ax + b = 0 (а <> 0). Знаю, задача но после С# сложно адаптироваться.

Ответ:
studentASH
studentASH
15.10.2020 13:13

package testStudentCode;

//import java.util.Arrays;

import java.util.Scanner;

public class TestStudentCode {

public static void main(String[] args) {

/* This reads the input provided by user

        * using keyboard

        */

       Scanner scan = new Scanner(System.in);

       System.out.print("a = ?");

       // This method reads the number provided using keyboard

       double a = scan.nextDouble();

       System.out.print("b = ?");

       double b = scan.nextDouble();

       // Closing Scanner after the use

       scan.close();

       System.out.println(a + "x + (" + b + ") = 0");  

       if (a == 0) {

        System.out.println("a = 0");

       } else {

           double x = - b / a;

        System.out.println("x = " + x);

       }

}

}

Объяснение:

как то так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?