В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Нікіта1111
Нікіта1111
14.09.2020 16:05 •  Информатика

Объясните задание, я реально не понимаю что от меня хотят "Написать программу, которая выводит число равное количеству цифр 4 в десятичной записи числа"
Желательно, с примерами

Ответ:
юра13t4
юра13t4
15.10.2020 13:14

#include<iostream>

#include<string>

using namespace std;

int main(){

   string n;

   cin >> n;

   long long ans = 0;

   for(long long i = 0; i < n.size(); i++){

       if(n[i] == '4'){

           ans++;

       }

   }

   cout << ans;

   return 0;

}

Объяснение:

Смотрите, на вход дается какое-то число а программа должна вывести кол-во 4 в этом числе.

Примеры

ввод 14 вывод 1

ввод 444 вывод 3

ввод 16484 вывод 2

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?