В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sezimturatbeko
Sezimturatbeko
10.12.2022 11:24 •  Информатика

Напишите программу, которая в последовательности натуральных чисел находит количество двузначных чисел, кратных 4, или сообщает, что таких чисел нет. Программа получает на вход
натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается
числом 0 (0 – признак окончания ввода, не является членом последовательности). Программа
должна вывести количество чисел, удовлетворяющих условию, или вывести NO, если таких
чисел в последовательности нет

Ответ:
penguin8
penguin8
15.10.2020 13:01

// PascalABC.NET

begin

 var k := ReadSeqIntegerWhile(p -> p <> 0)

   .Count(p -> (p mod 4 = 0) and (p in Range(10,99)));

 if k = 0 then

   Write('NO')

 else

   Write(k)  

end.

0,0(0 оценок)
Ответ:
Anna170806
Anna170806
15.10.2020 13:01
begin var n := ReadSeqIntegerWhile(x->x<>0).Count(x->(x mod 4 = 0) and (x in 10..99)); Write(n=0?'NO':n.ToString) end.

Пример работы:


Напишите программу, которая в последовательности натуральных чисел находит количество двузначных чис
Напишите программу, которая в последовательности натуральных чисел находит количество двузначных чис
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?