В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MGap58
MGap58
28.07.2022 00:38 •  Информатика

Написать программу на языке С

Напишите функцию заполнения массива 10-ю случайными числами в диапазоне от -40 до 40, функцию вывода элементов массива.

Ответ:
dssh70
dssh70
15.10.2020 12:52

//Братишка, я тебе С++ принёс

#include <iostream>

#include <ctime>

#include <cstdlib>

using namespace std;

void fill(int arr[10]){

   srand(time(NULL));

   for(int i = 0;i<10;i++){

       arr[i] = rand() % 81 + -40;

   }

}

void output(int arr[10]){

   for(int i = 0;i<10;i++){

       cout<<arr[i]<<endl;

   }

}

int main()

{

   int arr[10];

   fill(arr);

   output(arr);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?