В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
carollaim
carollaim
28.04.2020 14:10 •  Информатика

C#
Написать программу, в которой вводятся с клавиатуры предложения, и выводит на экран только цитаты, то есть предложения, заключенные в кавычки.

Ответ:
nactya201613
nactya201613
15.10.2020 12:45

using System;

using System.Text.RegularExpressions;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           string s;

           Console.WriteLine("Введите текст:");

           s = Console.ReadLine().Replace('\"','\'');

           Regex r = new Regex(@"'[^']+'");

           foreach (Match m in r.Matches(s))

               Console.WriteLine(m.Value);

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?