В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
анель1011
анель1011
14.07.2022 19:37 •  Информатика

Напишите программу в ПИТОНЕ, которая в последовательности целых чисел определяет количество нечётных чисел, кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.

Ответ:
rigorevich17
rigorevich17
15.10.2020 12:39

вот.............................

Объяснение:

k=0

i=0

x=int(input())

while x!=0:

if x%3==0 and x%2>0:

 k+=1

x=int(input())

i+=1

print(i)

print(k)


Напишите программу в ПИТОНЕ, которая в последовательности целых чисел определяет количество нечётных
0,0(0 оценок)
Ответ:
Dimaj
Dimaj
15.10.2020 12:39

import typing

from typing import Callable

def ReadSeqWhile(SeqType, predicate: Callable[[int], bool]):

   temp = SeqType(input())

   while predicate(temp):

       yield temp

       temp = SeqType(input())

def main():

   RawSequence = ReadSeqWhile(int, lambda x: x != 0)

   Selector = lambda item: (item % 3 == 0) and (item % 2 != 0)

   FilteredSequence = filter(Selector, RawSequence)

   print(f'Число элементов, удовлетворяющих условию: {len( list( FilteredSequence ) )}')

if __name__ == "__main__":

   main()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?