В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aium08
aium08
24.06.2020 21:11 •  Информатика

Напишите программу, которая в последовательности натуральных чисел находит
минимальное нечетное трехзначное число или сообщает, что таких чисел нет. На вход
программы подаются количество чисел n, а дальше сами числа x. Программа должна
вывести минимальное четное трехзначное число или вывести NO, если таких чисел в
последовательности нет. PASCAL ОЧЕНЬ

Ответ:
Аrvin
Аrvin
15.10.2020 11:04

var i, min, x, n:Integer;

begin

min:=1000;

 readln(n);

 for i := 1 to n do

 begin

   readln(x);

   if (x < min) and (x mod 2 <> 0) and (x>=100) and (x<1000) then  

   min:=x;

  end;

  if min = 1000 then  

writeln('NO')

else

writeln(min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?