В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Hi1666888888
Hi1666888888
20.10.2022 09:43 •  Информатика

очень ВАЖНО Вставка числа
Требуется вставить в данный массив на данное место данный элемент, сдвинув остальные элементы вправо.

Входные данные

В первой строке вводится одно натуральное число, не превосходящее 1000 — размер массива. Во второй строке задаются N чисел — элементы массива (целые числа, не превосходящие по модулю 1000). В третьей строке вводится число, которое необходимо вставить, и номер места, на которое его нужно вставить.

Выходные данные

Вывести получившийся массив.

Примеры
Ввод 1
5
1 2 3 4 5
2 3
Вывод
1 2 2 3 4 5
ОЧЕНЬ ВАЖНО

Ответ:
kristina231220
kristina231220
15.10.2020 11:04

n = int(input())

array = []

for i in input().split():

   array.append(int(i))

k, j = input().split()

k, j = int(k), int(j)

array = array[:j - 1] + [k] + array[j - 1:]

ret = str(array[0])

for i in range(1, len(array)):

   ret = ret + ' ' + str(array[i])

print(ret)

Объяснение:

слайсами суммируем массив

0,0(0 оценок)
Ответ:
sofya206
sofya206
15.10.2020 11:04

Используя метод list.insert

N = int(input())

arr = [int(i) for i in input().split()]

assert len(arr) == N #Пользователь обязан ввести ровно N чисел. Иначе вылет с исключением AssertionError

insItem, insPos = [int(i) for i in input().split()]

arr.insert(insPos, insItem)

print(arr)

Программа очень требовательна к формату ввода.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?