В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
shpirnoroman
shpirnoroman
28.01.2023 03:48 •  Информатика

Даны восемь целых чисел определите сколько из них положительных.
Язык C# Массив чисел.

Ответ:
568954
568954
13.08.2020 11:28

using System;

namespace Task

{

   class Program

   {

       static void Main(string[] args)

       {

           int[] numbers = {2,-27,-2,5,14,-88,54,-69};

           int count = 0;

           foreach (int number in numbers)

           {

               if (number > 0)

               {

                   count++;

               }

           }

           Console.WriteLine("Положительных чисел в массиве: "+count);

       }

   }

}

Программа считает количество положительных чисел больше нуля.

0,0(0 оценок)
Ответ:
ladiaginairina
ladiaginairina
13.08.2020 11:28
a.Count(x => x > 0);

Где a - массив чисел.

Пример программы:

namespace ConsoleTestApp{class Program{static void Main(string[] args){int[] a = { 12, -47, -6, 5, 34, 88, 59, -86 };Console.WriteLine(a.Count(x => x > 0));Console.ReadKey();}}}

Пример работы:


Даны восемь целых чисел определите сколько из них положительных. Язык C# Массив чисел.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?