В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Milykenon101
Milykenon101
07.08.2022 01:12 •  Информатика

Дано трехзначное число напишите программу которая определяет является ли число перевертышем. python

Ответ:
ВеликийМаг2018
ВеликийМаг2018
09.06.2020 16:51

number = input('Введите число: ')

c = len(number) // 2

d = len(number)

o = 0

x = True

for i in number:

   if (o <= c) and (i != number[d-1]) and (x == True):

       x = False

   o += 1

   d -= 1

if x:

   print('Число является перевёртышем')

else:

   print('Число не является перевёртышем')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?