В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
en228
en228
18.06.2022 00:20 •  Информатика

PascalABC. Написать программу, в которой выполняются следующие действия:
1. с клавиатуры вводится имя 1-го человека;
2. с клавиатуры вводится вес 1-го человека;
3. с клавиатуры вводится имя 2-го человека;
4. с клавиатуры вводится вес 2-го человека;
5. программа выводит имя более тяжелого человека (при равенстве весов
выводится имя 2-го человека);
6. в том случае, когда вес какого-либо человека или обоих не находится в
пределах от 3 до 150 программа выводит только сообщение «ошибка».

Ответ:
vlad070504
vlad070504
15.10.2020 07:18

var

a, b:String;

c, d:Integer;

begin

readln(a);

readln(c);

if (c < 3) or (c  > 150)

then begin

 writeln('Ошибка');

 exit;

 end;

readln(b);

readln(d);

if (d < 3) or (d  > 150)

then begin

 writeln('Ошибка');

 exit;

end;

if c > d then  

 writeln(a)

else  

writeln(b);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?