В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KarinochkaShiну
KarinochkaShiну
26.06.2022 16:42 •  Информатика

Написать программу для решения . дана строка, содержащая текст на языке, и некоторая буква. подсчитать, сколько слов начинается с указанной буквы. не копируйте существующие, не работают

Ответ:
Yogurt1958
Yogurt1958
09.06.2020 15:16

program raf105;

var

 s:string;

 b:char;

 o,i:integer;

begin

write('Введите строку: ');

readln(s);

write('Введите искомую букву: ');

readln(b);

s:= lowercase(s);

b:= lowercase(b);

if s[1] = b

 then o+=1;

for i:=2 to length(s) do

 if (s[i]=b) and (s[i-1]=' ')

   then o+= 1;

writeln('С буквы "',b,'" начинается ',o,' сл.');

end.

Язык PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?