В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
zulya24
zulya24
05.02.2023 18:08 •  Информатика

Задачи «Цикл с предусловием»
1 Напишите программу, в которой осуществляется ввод целых чисел (ввод
осуществляется до тех пор, пока не будет введён ноль) и подсчёт суммы
и среднего арифметического введённых положительных чисел.
2 Напишите программу, в которой осуществляется ввод целых чисел (ввод
осуществляется до тех пор, пока не будет введён ноль) и определение
максимального (наибольшего) из введённых чисел.

Ответ:
345153
345153
15.10.2020 06:45

Объяснение:

Язык не был указан, так что пишу на С++:

1)

#include <iostream>

using namespace std;

int main()

{

   int buf, quantity = 0;

   cin >> buf;

   int sum = 0;

   while (buf != 0) {

       ++quantity;

       sum += buf;

       cin >> buf;

   }

   cout << "Sum: " << sum << "\nAverage: " << sum / quantity;

}

2)

#include <iostream>

using namespace std;

int main()

{

   int buf;

   cin >> buf;

   int max_num = buf;

   while (buf != 0) {

       if (max_num < buf) {

           max_num = buf;

       }

       cin >> buf;

   }

   cout << "Max: " << max_num;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?