В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
elenaivanovad
elenaivanovad
12.06.2022 15:39 •  Информатика

Написать программу на C++
Дана матрицы из 3 строк и 7 столбцов. Рассматривая содержание каждого элемента столбца как длину стороны треугольника, отпечатать номера столбцов, которыми заданы равнобедренные треугольники, и число таких столбцов.

Ответ:
antonuku977
antonuku977
15.10.2020 06:59

#include <iostream>

#include <vector>

using namespace std;

bool ok1(int a, int b, int c){

   return (a+b > c && a+c > b && b+c > a) && min(a,min(b,c)) > 0;

}

bool ok2(int a, int b, int c){

   return ok1(a,b,c) && (a == b || a == c || b == c);

}

signed main(){

   const int n = 3, m = 7;

   int arr[n][m];

   for(int i = 0; i < n; i++)

       for(int j = 0; j < m; j++)

           cin >> arr[i][j];

   vector<int> ans;

   for(int j = 0; j < m; j++)

       if(ok2(arr[0][j],arr[1][j],arr[2][j]))

           ans.push_back(j+1);

   cout << ans.size() << "\n";

   for(auto i: ans)

       cout << i << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?