В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
555767
555767
28.06.2021 18:48 •  Информатика

30 напишите программу для решения следующей . в некотором году на участке в к гектаров средняя урожайность ячменя составила а центнеров с гектара. после этого каждый год площадь участка увеличивалась на р%, а средняя урожайность - на в%. через сколько лет урожай превысит м центнеров.

Ответ:
Bogatuk2005
Bogatuk2005
09.06.2020 14:26

program raf105;

var k,a,p,b,m,let:real;

begin

write('Площадь участка (га.): ');

readln(k);

write('Средняя урожайность с гектара (ц.): ');

readln(a);

write('Увеличение участка за год (% от площади): ');

readln(p);

write('Рост урожайности за год (% от урожайности): ');

readln(b);

write('Желаемый урожай (ц.): ');

readln(m);

while a < m do

begin

 k+= (k/100*p);

 a+= (a/100*b);

 let+= 1;

end;

writeln;

writeln('Желаемая урожайность (',m,' ц.) будет достигнута через ',let,' лет');

writeln('При этом, площадь участка будет составлять примерно ',round(k),' га.');

end.

Язык PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?